Azure DevOps Server 2020: Missing Sprint Burndown Dashboard Widgets


I recently did an Azure DevOps Server 2020 upgrade for a client. We took their Team Foundation Server 2017 (TFS2017) instance, migrated the data to new hardware, and upgraded it to Azure DevOps 2020.

Everything seemed to be fine but we got a report of a strange issue with the project Dashboards. This user wanted to create a Dashboard view about sprint progress for their Scrum teams. Specifically, she wanted to add the Sprint Burndown widget to the dashboard but she found that on some projects it wasn’t showing up as an available option. Some projects had the “Sprint Burndown” and “Sprint Burndown (Legacy)” widgets while other projects simply had the “Sprint Burndown (Legacy)” widget.

The Add Widget dialog on the left is missing the new Sprint Burndown widget

Why was this happening? After much head-scratching, it turns out that the Analytics option was not turned on for one of the Team Project Collections. You can view this setting by going to the web interface for your Azure DevOps Server instance, choosing a Team Project Collection, and clicking on the Collection Settings button. Once you’re on the Collection Settings admin page, choose Analytics from the left side menu.

Analytics is not enabled for the Team Project Collection

After clicking the Enable Analytics button for that Team Project Collection, the UI should say that the data is being prepared.

Analytics enabled. Data is being prepared.

Once this screen reports that Analytics are enabled, you should see the missing widgets in the Dashboard options.

I hope this helps,

Looking for help with Azure DevOps or Team Foundation Server? Want assistance migrating your on-prem instances to the cloud? Need some guidance on how to help your Scrum teams be successful at software delivery wit Azure DevOps? We can help. Drop us a line at

6 Responses to "Azure DevOps Server 2020: Missing Sprint Burndown Dashboard Widgets"
  1. Thanks Ben. I typically find your blogs and guides very helpful – so thank you for sharing. With this specific issue, I upgraded our company’s TFS instance from TFS2017 to AzureDevOpsServer2020 back in April 2021. At that time, I enabled Analytics following the same steps you have listed. However, I am still running into problems where the burndown charts are still not showing … and instead yield an error of Error: TFS.WebApi.exception: 503 Service Unreachable.

    My question: have you come across this before? I would think that a couple of months should be sufficient for Analytics to be complete and start working to produce burndown charts. But something tells me somehow there is some underlying service that didn’t start right. Any thoughts or suggestions?

  2. Hi Rick —

    That’s definitely strange. That 503 status sounds like the widgets are showing up ok but that there’s something unhappy on the server. Do you see any interesting messages in the event log on the application tier machine? Have you tried using something like Fiddler or maybe the dev tools in Chrome/Edge to try to diagnose what’s going on with those failing HTTP requests?


    • Wow, thanks much for the lightning-fast response! Great suggestions indeed. I should have mentioned that I was looking into fiddler to make sense of things back when I originally posted. As it stands now, I haven’t found anything substantial yet, but I am confident I’ll get ‘er figure it out; was simply thinking if someone already knew it might save me some time; and your post was close to the error – at least within the topic area anyway.

      That said, I did try reviewing event log items (Microsoft-Team Foundation Server events) but found no success. Will try browser dev tools to also see if that yields any fruit. Thanks much Ben

Leave a Reply to Rick Carter Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: